Page 1 of 1

Will Cute Knight Deluxe Work Properly on Window 7 64 Bit?

Posted: Thu Aug 05, 2010 1:11 am
by Saetana
I've just reinstalled my copy of Cute Knight Deluxe on my new PC, which is running 64 bit Windows 7, and I am getting a lot of error messages about non-existant sprites - some of these it will let me ignore without difficulties but when I tried to go to the festival in the square I got another error message, ignored it again, but this time the trader illustration popped up in the bottom left hand corner but there was no list of things to choose to do, hence I was stuck and had to exit the game.

Is it possible to play the game on my new PC or is this problem due to another cause?

Posted: Thu Aug 05, 2010 1:18 am
by Saetana
This is the error message I was getting most frequently:

action number 1
of Mouse Event for Glob Left Pressed
for object action_button:

Trying to delete non-existing background.

action number 1
of Alarm Event for alarm 0
for object first_intro_controller:

Trying to replace non-existing sprite.

Posted: Thu Aug 05, 2010 1:20 am
by hanako
The original Cute Knight was written well before Vista came out, much less 7, and couldn't predict how things would change, so it's certainly possible that they've changed things enough that the old games can't run anymore. I don't *have* a Windows 7 computer (for that matter, I don't actually have Vista, just some Vista testers) so I can't verify what does and doesn't work.

You say you're using Deluxe, right? (Which should therefore be Vista-capable.)

Does the demo work, or produce similar errors? If a fresh copy of the demo produces the same errors then it's probably not 7 compatible. Let me know if that's the case so I can put warnings on the game webpage...

If the demo works, it's possible there was something wrong with your installer.

Posted: Thu Aug 05, 2010 8:14 pm
by Saetana
Yes the demo works fine, I have to admit I couldn't see what the problem was as I have older games than Cute Knight that play fine on my new PC. Should I download the installer again via my original email link or will this be the same as the copy I originally tried to install? The installer I used was simply a backed-up copy of the installer I obtained via my original email link when I first bought the game.

Posted: Thu Aug 05, 2010 8:22 pm
by Saetana
I have just tried to use my original email link to redownload the installer but it came up with "password expired" and the email address for BMT Micro. I have written to them to ask for a new link but am still concerned as to whether this new link (assuming I can get one) will work any better than the original installation file.

I have just taken a close look at my original receipt and it said the password expired on 22nd December 2009 (I bought the game on 21st November 2009) and to have downloaded my game by then. I'm now wondering if they will actually send me another link and, if not, is there any way I can get a copy to unlock another way?

Posted: Thu Aug 05, 2010 8:34 pm
by hanako
It's possible to badger BMT to send you a new link, but it's a lot easier to send your recipt details to *me*. :)

However, if you bought in 2009 then the installer there would not have been changed in the meantime, so it shouldn't make any difference. I'm really not sure why your game is having problems, then. However, there is something I can do. If you email or PM me your order records I will see if I can get you a copy of the alternate version of the game, the one that uses the same engine as the Mac and Linux builds. That's NOT the one you'd get from the regular installer (or demo) but it's built on a different codebase so it might work where another doesn't.


Posted: Fri Aug 06, 2010 5:30 am
by Saetana
Well, I actually managed to get my link reactivated by BMT without any badgering, lol, which surprised me. I installed the game and it now works fine so I have no idea what went wrong with the original copy. I shall back the installer up to a flash drive and hope that it works if I ever need to reinstall the game again.

Thank you very much for your assistance, looks like the cause of the error messages shall forever remain a mystery ;o)