Debug Codes

Rule the world - or die trying!
Message
Author
User avatar
hanako
Site Admin
Posts: 3188
Joined: Fri Apr 13, 2007 1:44 am

Re: Debug Codes

#31 Postby hanako » Sat Nov 16, 2013 11:10 pm

Once you've hit enter twice like the instructions say, the way to leave should be more obvious. :)

User avatar
Duszynski
Posts: 6
Age: 30
Joined: Sat Nov 16, 2013 11:00 pm
Contact:

Re: Debug Codes

#32 Postby Duszynski » Sat Nov 16, 2013 11:13 pm

hanako wrote:Once you've hit enter twice like the instructions say, the way to leave should be more obvious. :)


Um, I have. :/

Image

User avatar
hanako
Site Admin
Posts: 3188
Joined: Fri Apr 13, 2007 1:44 am

Re: Debug Codes

#33 Postby hanako » Sat Nov 16, 2013 11:40 pm

That's entering two lines of code. You need to enter one line of code, then hit enter twice. (The enter on a blank line tells the debugger to execute the code you've input so far. Until that point nothing has actually been run.)

User avatar
Duszynski
Posts: 6
Age: 30
Joined: Sat Nov 16, 2013 11:00 pm
Contact:

Re: Debug Codes

#34 Postby Duszynski » Sat Nov 16, 2013 11:46 pm

hanako wrote:That's entering two lines of code. You need to enter one line of code, then hit enter twice. (The enter on a blank line tells the debugger to execute the code you've input so far. Until that point nothing has actually been run.)


Oh! Thank you. I totally misunderstood. Sorry about that.

User avatar
Ariel Schnee
Posts: 147
Age: 46
Joined: Wed May 23, 2007 3:51 am
Location: USA In The Northern Part Of Louisiana
Contact:

Re: Debug Codes

#35 Postby Ariel Schnee » Sun Nov 17, 2013 2:13 am

Duszynski wrote:This is probably a dumb question, but I can't figure out how to exit the Debugger Console. There doesn't seem to be an option to exit it and I've tried hitting "escape" but that doesn't work.


Trying hitting 'return'.
---

Signature

If you are a believer of Jesus Christ, and are 100% proud of it, put this in your sig!!

- Ariel Schnee, twin sister of Weiss Schnee, Loyal Servant of The Royal Pony Sisters Princess Celestia and Princess Luna... Forever Equestria!

User avatar
zonohedron
Posts: 17
Joined: Wed Apr 16, 2014 11:53 pm

Re:

#36 Postby zonohedron » Thu May 08, 2014 1:52 pm

Rhidian wrote:Speaking of Hidden Stats:


commoner_approval
noble_approval
cruelty
lassi

Cruelty normally goes 0-10


Is there a command for displaying the current value of the hidden stats (as opposed to just changing them?) I don't want to set cruelty (or any of the others) to something; I just want to know what the current value is.

User avatar
Spiky Caterpillar
Posts: 402
Joined: Thu Dec 04, 2008 3:34 am
Contact:

Re: Debug Codes

#37 Postby Spiky Caterpillar » Fri May 09, 2014 7:03 pm

Code: Select all

narrator("%(cruelty)d")
narrator("%(lassi)f")


should work. (noble_approval and commoner_approval also get a d suffix)

User avatar
zonohedron
Posts: 17
Joined: Wed Apr 16, 2014 11:53 pm

Re: Debug Codes

#38 Postby zonohedron » Fri May 09, 2014 10:15 pm

That just gives me %(cruelty)d. (And the same for the others.)

User avatar
Spiky Caterpillar
Posts: 402
Joined: Thu Dec 04, 2008 3:34 am
Contact:

Re: Debug Codes

#39 Postby Spiky Caterpillar » Fri May 09, 2014 10:33 pm

Oops, misremembered the code. Try

Code: Select all

narrator(str(cruelty))

User avatar
zonohedron
Posts: 17
Joined: Wed Apr 16, 2014 11:53 pm

Re: Debug Codes

#40 Postby zonohedron » Fri May 09, 2014 10:45 pm

That works! Thank you!

KironD63
Posts: 2
Joined: Sun Jan 18, 2015 2:34 am

Re: Debug Codes

#41 Postby KironD63 » Sun Jan 18, 2015 2:36 am

I'm entering in Debug codes correctly and getting the "Execution Successful" message, but after I select "Done" and then load my saved game, I'm not actually seeing any changes in the game I'm playing that correspond with the codes I'm entering.

User avatar
hanako
Site Admin
Posts: 3188
Joined: Fri Apr 13, 2007 1:44 am

Re: Debug Codes

#42 Postby hanako » Sun Jan 18, 2015 2:40 am

If you load a saved game, then immediately all the values will be changed to the values they were when the game was saved.

Histidine
Posts: 1
Joined: Sat Nov 14, 2015 4:08 am

Re: Debug Codes

#43 Postby Histidine » Sat Nov 14, 2015 4:30 am

So here's something I did a long time ago for my own convenience...
(wanted to post here earlier but got lazy)

Quick cheats
To install: Put cheats.rpy in LongLiveTheQueen/game

Commands:

setSkill("<skillName>", <num>)
setAllSkills(<num>)
- e.g. setSkill("public_speaking", 30)
- Sets both the temporary and permanent skill stats (i.e. takes effect immediately, won't be reset by classes)

unlockAllOutfits()

setMood("<mood>", num)
- Moods are: anger, cheerfulness, willful, crowded
- e.g. setMood("anger", -1) to have 1 Anxious
- Changes current overall mood immediately if applicable

Thanks to hanako and Rhidian for the codes.

AlwaysFr3sh
Posts: 2
Joined: Sun Oct 30, 2016 5:53 pm

Re: Debug Codes

#44 Postby AlwaysFr3sh » Sun Oct 30, 2016 5:58 pm

I recently opened the debug menu for the first time and wanted to try cheating (since I've completed the game multiple times) in the end, I didn't input any but now my game won't load properly.

When I open it with Steam then it appears in a small pop-up window and I can't click anything, it then crashes if I try to fullscreen it. Is there any way for me to fix it?
btw, a few months before a bought the game with steam, I used this website to download a trial version for the first 10 weeks, should I delete that?
:( :( :( :( :( :( :(


Return to “Long Live The Queen”

Who is online

Users browsing this forum: No registered users and 5 guests