Page 1 of 2

Game Startup Problem On Mac Lion

Posted: Mon Jun 25, 2012 4:41 pm
by Vitanimus
I played through the demo on my mac (OS X Lion) and all worked fine, so I bought the game and continued to play without any problems. When I was done for the evening I closed it down, and now when I try to start the game up, the screen goes black as if its loading, goes blue, then returns to my desktop. It's still technically open as the toolbar displays 'Long Live the Queen' but the spinning rainbow beach ball is there, and I have to emergency quit.

I've tried turning it off again, and uninstalled then reinstalled the game, and the problem is still the same. I don't suppose you could make any guesses as to what's gone wrong?

Problems aside, it's a really great game! I love all the dying, much more challenging. Just a bit devastated that I can't play it any more :wink:

Posted: Mon Jun 25, 2012 4:50 pm
by mjm1215
Maybe you're running something in the background that's conflicting with it. Have you tried going to something like msconfig on a PC and unchecking all of non-essential startup processes and then restarting? That works for me sometimes.

I know this might not be any help since Macs are so different than PCs, but you've probably got some way you can choose which programs and processes start up when your computer starts up.

Posted: Mon Jun 25, 2012 4:54 pm
by hanako
My initial guess would be that somehow the graphics configuration has gotten messed up, although I'm not entirely sure how. If you hold down shift when you launch the game, do you get a graphics-choice screen?

A graphics preference glitch would persist even after uninstall/reinstall because those preferences are stored with your saved games, not in the game directory.

Posted: Mon Jun 25, 2012 4:58 pm
by Vitanimus
mjm, I've checked and I don't have anything going on at startup, so I don't think that can be it. Thanks, though!

hanako, Shift+Click only attempts to start the game up again...

Posted: Mon Jun 25, 2012 5:38 pm
by Spiky Caterpillar
What happens if you click on the Long Live The Queen icon in the Dock? If the toolbar says 'Long Live The Queen', does pressing 'F' do anything? (It should switch into or out of full screen mode, which will force
the game to reinitialize graphics.) Does alt-tabbing out and then back in make it work?

When you purchased the game for the first time, did you download the zip or update from within the game?

Posted: Mon Jun 25, 2012 5:41 pm
by Vitanimus
Opening it from the Dock gets the same results, and pressing 'F' and alt-tabbing doesn't do anything either...

I updated it from within the game, but when that didn't work I uninstalled it and then downloaded the ZIP.

Posted: Mon Jun 25, 2012 5:57 pm
by Spiky Caterpillar
A clarification: what I meant by clicking on it in the Dock is to start the game from the folder it's in, THEN click the icon in the Dock once it's loaded. Another workaround that may work is, if it's running (the menubar says Long Live The Queen and the music is playing), try right-clicking on it in the Dock, minimizing, and un-minimizing.

If you install the demo, does it start normally or does it also start minimized?

Lion does some strange things with trying to remember window status that break some programs occasionally, and unfortunately this behaviour is unpredictable enough that it's a little difficult to tell when it's actually fixed (and updates may change it again.)

I'll be trying to come up with a proper fix for the next version, as well - we'll PM you when there's an updated installer for you to check.

Posted: Mon Jun 25, 2012 6:06 pm
by Vitanimus
Ah, I see. Okay, I've just tried that method too and it didn't do anything new, nor did minimising and maximising again. It doesn't play the music, though, not at all.

Even the demo has stopped working for me, but when I installed it originally, it started normally.

Thanks for all your help, even if I still can't open it :) I really appreciate it, and I'll be looking out for the PM.

Posted: Wed Jun 27, 2012 4:05 am
by Spiky Caterpillar
I've PM'd you a version with a candidate fix.

(If anyone else is having this or a similar problem, please let me know.)

Same issue

Posted: Thu Jun 28, 2012 3:55 am
by Senbi
I'm having the exact same problem described. I have the demo version which I played repeatedly last night. I think I had it in full screen mode when I stopped playing. I tried to start the game today, to give it one more run before deciding whether or not to purchase. The game attempts to load as the other user describes, flickers briefly between black and blue and then goes to desktop where I can only force-quit the game. I shut down almost all other programs, rebooted, downloaded demo again, etc to troubleshoot. No luck.

I am playing on a macbook air with lion.

Thanks for any help.

Posted: Thu Jun 28, 2012 6:50 am
by Spiky Caterpillar
I've got an alpha-test fixed Mac version of the demo up at
(EDIT: 1.0.1 is obsolete; download
http://spikycaterpillar.com/demos/LongL ... .5-mac.zip instead.)

It also adds some fixes for minor issues, and the mood button on weekends, but hasn't been tested properly yet - I just built it a minute ago.

Download that and let us know if it works for you?

The bug is also present in the full version. You can either PM me your order details and I'll send you a download username/password for an updated fullbuild, or if you don't want to wait for PMs you can use the new demo and the updater to fix it:

To fix the full version:
Start the 1.0.1 demo.
Switch the game into windowed mode.
Quit the demo.
Start the full version.
Go to the updater and enable beta *and* alpha patches. (The alpha button won't show up until beta patches are enabled.)
Update the full version to 1.0.8.

You can also force the game into windowed mode by deleting the persistent data file (rm ~/Library/RenPy/LongLiveTheQueen/persistent from the Terminal), but note that that will also clear any checklist entries.

Once the full version is updated to 1.0.8, it should be able to start normally in fullscreen mode on Lion.

Let us know if the fixes work for you.

Posted: Thu Jun 28, 2012 2:41 pm
by Senbi
I downloaded the 1.0.1 demo but it didn't resolve the issue. I deleted the persistent data file and that did let me open up the game in windowed mode. Let me know (I'm watching this forum) if you have additional demo updates you'd like me to test.

Mood Button

Posted: Thu Jun 28, 2012 2:49 pm
by Senbi
Just tested the mood button in the 1.0.1 demo. The game crashed and I received this error message:

I'm sorry, but an uncaught exception occurred.

While running game code:
File "game/script.rpy", line 42, in script call
File "game/weekends.rpy", line 26, in script
ScriptError: could not find label 'mood_weekend_page'.

-- Full Traceback ------------------------------------------------------------

Full traceback:
File "/Users/Justine/Downloads/LongLiveTheQueen-1.0.1-mac/LongLiveTheQueen.app/Contents/Resources/autorun/renpy/bootstrap.py", line 274, in bootstrap
File "/Users/Justine/Downloads/LongLiveTheQueen-1.0.1-mac/LongLiveTheQueen.app/Contents/Resources/autorun/renpy/main.py", line 354, in main
File "/Users/Justine/Downloads/LongLiveTheQueen-1.0.1-mac/LongLiveTheQueen.app/Contents/Resources/autorun/renpy/main.py", line 95, in run
File "/Users/Justine/Downloads/LongLiveTheQueen-1.0.1-mac/LongLiveTheQueen.app/Contents/Resources/autorun/renpy/execution.py", line 275, in run
File "/Users/Justine/Downloads/LongLiveTheQueen-1.0.1-mac/LongLiveTheQueen.app/Contents/Resources/autorun/renpy/script.py", line 485, in lookup
ScriptError: could not find label 'mood_weekend_page'.

Darwin-11.4.0-x86_64-i386-32bit
Ren'Py 6.12.2.1531
Long Live The Queen 0.1

Posted: Thu Jun 28, 2012 10:12 pm
by Spiky Caterpillar
Senbi wrote:I downloaded the 1.0.1 demo but it didn't resolve the issue. I deleted the persistent data file and that did let me open up the game in windowed mode. Let me know (I'm watching this forum) if you have additional demo updates you'd like me to test.
(Never mind the instructions about the log, there's more that I need to fix first.)

Posted: Thu Jun 28, 2012 10:21 pm
by Spiky Caterpillar
(Also, if you update the demo to alpha 1.0.2, that should fix the mood crash on weekends.)