Page 1 of 7

Bug reporting help

Posted: Mon Jan 31, 2011 2:30 pm
by Spiky Caterpillar
First, always post the version number of your version of Magical Diary in any bug report! You can check your version number by going to the Options screen and selecting *Updater* - it will show you the current version, the original version, and any partial update information.

If you need to upload saved games or screenshots (or any type of file, actually) to us and don't have your own webspace, you can use the form at to send the files.

If you encounter graphical bugs, you can take screenshots from inside the game by pressing the S key (in most places.). If you encounter display corruption, or if a bug shows up onscreen but NOT in the screenshot, the bug is probably a GL bug and you'll need to post the opengl.txt file the game produces.

If you're using Windows 7 or Vista, text files and screenshots may wind up being dropped in C:\Users\(Your_user_name)\AppData\Local\VirtualStore\Program Files\(Application_name) . Otherwise, text files and screenshots should be dropped in the main game directory.

If the game crashes when you're updating or uploading a traceback, let us know - if you have a very old version of the game, we may need to give you a new installer; otherwise, it's probably a bug we need to fix.

If the game gives you a 'permission denied' error when you try to update, try again in a minute or two - we might be in the middle of adding a brand new patch. If the game STILL gives errors when you're trying to update even after you wait a few minutes, then we need to know.

Posted: Mon Feb 07, 2011 8:39 pm
by Ellume
Well I found a minor bug. Version running on ubuntu linux.

At the dark dance event, the choices I made (spirit sight) lead to:
Potsdam: It wouldn't be a good idea for you to return to the dance now. Off to bed with you, then.
which makes sense but then just a couple lines later it says
I'll just have to take it on faith.
Surrounded by friends and strangers, I dance the night away.
I'm assuming a minor plot branch mistake, obviously the character doesn't dance after being sent back alone to her room.

Posted: Mon Feb 07, 2011 10:01 pm
by Spiky Caterpillar
Update to or later and it should be fixed - only updates the updater, not the rest of the game. (... and I need to make updater stubs warn people that they'll need to update again. Oops.)

Posted: Tue Feb 08, 2011 2:18 am
by Ellume
Updated to One thing I found strange was on my second play through I didn't go to the magic store at the mall until quite late in the game (during the candle selling) and the description
With Virginia's vague directions in mind, I set out in search of the magic store.
seemed kind of out of place. Thinking "why did Virginia suddenly pop into the picture?" On my first play through I went with Virginia to the mall and straight to the magic store, and at that time the description fits perfectly since the character was just talking with Virginia. Minor thing but I thought I would share what I thought. Otherwise this is turning out exceptional on several levels.


Posted: Tue Feb 15, 2011 7:24 am
by jyrayos
I think I might need a new updater because I try to use the updater for the game. When I play it, the game continues to end on winter break instead of continuing into Jan. 15.

Posted: Tue Feb 15, 2011 2:58 pm
by hanako
When you go to the updater screen, what version does it currently say you have, and what happens when you try to update?

Are you loading from a saved game that's on the day it stopped for winter break? It's probably a good idea to back up a little so that the game can properly reload the changed area.


Posted: Mon Feb 28, 2011 5:48 am
by Nada
I'm updated to Version:

Basically I followed the romance path for Damien and at the part were he asks the PC to go out with him I get an exception.

Posted: Mon Feb 28, 2011 6:02 am
by J_Yum1978
I got the same error. You have to load a saved game that you saved before January 24. I tried that and it worked fine.

Posted: Mon Feb 28, 2011 6:15 am
by Aetheria
In the event with Donald and Luke on January 13, for a few screens Donald's sprite appears lower down - after "This is weird..." etc. - and then goes back to normal position. (I'm playing

Posted: Mon Feb 28, 2011 2:03 pm
by hanako
I got the same error. You have to load a saved game that you saved before January 24. I tried that and it worked fine.
edit - sorry, I misread this at first. You're probably right, I just shouldn't answer posts when half awake. :)

Something has changed in the timing for that area in one of the latest patches, and we're looking at it at the moment. Most likely you can avoid this problem by not using saves made after King Day on older versions - so yeah, start from before the 20th of January. I'll let Spiky provide more details if he's finished poking at it.

In general, if you get one of those exceptions with a tiny tiny traceback that can't be uploaded, the traceback itself is not helpful (because of the way it crashed, the traceback ended up with no information in it - the "while running game code" part is blank!) and the best thing to do is describe exactly where you were and what you were doing when it happened, and upload a saved game that allows us to replicate the problem.

Posted: Mon Feb 28, 2011 4:01 pm
by Nada
Ah, Okay. =) Well let me know if you need anymore info about it I can take a screen cap or upload the save if you need me to. =)

Posted: Mon Feb 28, 2011 6:49 pm
by Spiky Caterpillar
If you've got a save that crashes on January 25th with KeyError: 25, the best workaround is to first make sure that you're using a version more recent than, then load a save that was made on January 20th (in-game time) or earlier.

(The crash is caused by a bug in the scheduler on the 21st - it was setting the scheduled activity for the 20th to None, since there were no standard classes, but the game then runs every scheduled activity until there are none left. Since it never ran one on 20th, it couldn't clear the 20th, so on Saturday morning it attempted to send you to the next class. Which didn't exist.)

Posted: Fri Mar 04, 2011 8:43 pm
by ladysasuke
I'm sorry, but an uncaught exception occurred.

TypeError: set_mode() takes exactly 3 arguments (2 given)

After initialization, but before game start.
- python at line 406 of /home/deekoo/code/renpy-projects/MagicalDiary/game/glpatch.rpy.

-- Full Traceback ------------------------------------------------------------

File "C:\Program Files\Magical Diary - Horse Hall\renpy\", line 270, in bootstrap
File "C:\Program Files\Magical Diary - Horse Hall\renpy\", line 371, in main
File "C:\Program Files\Magical Diary - Horse Hall\renpy\display\", line 1153, in __init__
File "C:\Program Files\Magical Diary - Horse Hall\renpy\display\", line 1285, in set_mode
File "/home/deekoo/code/renpy-projects/MagicalDiary/game/glpatch.rpy", line 406, in GLDraw_set_mode
TypeError: set_mode() takes exactly 3 arguments (2 given)

After initialization, but before game start.
- python at line 406 of /home/deekoo/code/renpy-projects/MagicalDiary/game/glpatch.rpy.

Ren'Py Version: Ren'Py 6.11.2b

Magical Diary Verson 0.2.98 running on Windows Xp

Posted: Fri Mar 04, 2011 9:37 pm
by Spiky Caterpillar
Also, what resolution are you using? It looks like a downscaling bug, which may be fixed by updating (if you can) or worked around by with the shift key held down and telling the game to force software mode or GL mode.

What's the contents of your opengl.txt file?

Posted: Fri Mar 04, 2011 10:36 pm
by ladysasuke
I was trying to update the preorder version and i'm set to the highest resolution.