Page 5 of 7

Posted: Wed May 11, 2011 11:15 am
by hanako
Need more information!

What sort of computer do you have?

What exactly happens when you try to update?

Posted: Wed May 11, 2011 11:44 am
by Benazir
Windows XP

Last days nothing occurs after I click *Check for updates*.

I've updated the game from version 0.2.76 (when I ordered MD) to 0.3.68.1. And every day I check updates, but after version 0.3.68.1. ... it stopped.

Posted: Wed May 11, 2011 12:27 pm
by hanako
If nothing happens, that sounds like there's a network problem between your computer and the update server. Spiky may have more information, but otherwise the best I can suggest is to try again later.

If it can't reach the update server, it can't display the list of versions, so it just sits there.

Posted: Wed May 11, 2011 12:38 pm
by Benazir
hanako wrote:best I can suggest is to try again later.
I know, but it doesn't help. :(

Posted: Wed May 11, 2011 1:13 pm
by hanako
If nothing else, when we hit code completion I can give you a new full installer.

Posted: Wed May 11, 2011 7:02 pm
by Spiky Caterpillar
Benazir wrote:Windows XP

Last days nothing occurs after I click *Check for updates*.

I've updated the game from version 0.2.76 (when I ordered MD) to 0.3.68.1. And every day I check updates, but after version 0.3.68.1. ... it stopped.
I suspect some sort of network problem, but I'm not completely sure. What do you get if you go to http://updates.spikycaterpillar.com/mag ... ary/latest in a web browser? Are you using any form of proxy or filtration software?

Posted: Wed May 11, 2011 10:38 pm
by Benazir
Oh, now I can update MD to version 0.3.79.1. Thanks. :)
Spiky Caterpillar wrote: I suspect some sort of network problem, but I'm not completely sure. What do you get if you go to http://updates.spikycaterpillar.com/mag ... ary/latest in a web browser?
This:
stable 0.3.79.1
beta 0.3.79.2
alpha 0.3.80.1
Spiky Caterpillar wrote: Are you using any form of proxy or filtration software?
I don't think so ... :?

Posted: Wed May 11, 2011 10:55 pm
by Benazir
But I can't start the game after last updates .... I get this:

I'm sorry, but an uncaught exception occurred.

KeyError: 'fierce'

While executing init code:
- script at line 32 of /home/deekoo/code/renpy-projects/MagicalDiary/game/week19.rpy
- python at line 38 of /home/deekoo/code/renpy-projects/MagicalDiary/game/week19.rpy.
- python at line 36 of /home/deekoo/code/renpy-projects/MagicalDiary/game/week19.rpy.
- python at line 1545 of /home/deekoo/code/renpy-projects/MagicalDiary/game/magical_diary.rpy.

-- Full Traceback ------------------------------------------------------------

File "D:\Program Files\Magical Diary - Horse Hall\renpy\bootstrap.py", line 270, in bootstrap
File "D:\Program Files\Magical Diary - Horse Hall\renpy\main.py", line 327, in main
File "D:\Program Files\Magical Diary - Horse Hall\renpy\execution.py", line 259, in run
File "D:\Program Files\Magical Diary - Horse Hall\renpy\ast.py", line 574, in execute
File "D:\Program Files\Magical Diary - Horse Hall\renpy\python.py", line 957, in py_exec_bytecode
File "/home/deekoo/code/renpy-projects/MagicalDiary/game/week19.rpy", line 38, in <module>
File "/home/deekoo/code/renpy-projects/MagicalDiary/game/week19.rpy", line 36, in PotsdamCharacter
File "/home/deekoo/code/renpy-projects/MagicalDiary/game/magical_diary.rpy", line 1545, in PotsdamTalkerSprite
KeyError: 'fierce'

While executing init code:
- script at line 32 of /home/deekoo/code/renpy-projects/MagicalDiary/game/week19.rpy
- python at line 38 of /home/deekoo/code/renpy-projects/MagicalDiary/game/week19.rpy.
- python at line 36 of /home/deekoo/code/renpy-projects/MagicalDiary/game/week19.rpy.
- python at line 1545 of /home/deekoo/code/renpy-projects/MagicalDiary/game/magical_diary.rpy.

Ren'Py Version: Ren'Py 6.11.2b

Posted: Thu May 12, 2011 12:51 am
by reni344
I can't see the newest update on my game updater is there a way I can fix this?

Posted: Thu May 12, 2011 1:17 am
by hanako
What DO you see?

If you don't see any versions listed at all, then again, that's just a network hiccup - wait or try again later.

We didn't change anything for Benazir... it's just the internet inbetween doing its own weird thing as it sometimes does. :)

Posted: Thu May 12, 2011 1:33 am
by reni344
I see 0.379.2 for the version and 0.3.801 for the beta version and then 0.381.2 for the alpha version.

Posted: Thu May 12, 2011 1:35 am
by hanako
... those were the newest updates. So what was the problem?

Posted: Thu May 12, 2011 1:41 am
by reni344
it works now.

Posted: Thu May 12, 2011 6:23 am
by Benazir
hanako wrote: We didn't change anything for Benazir... it's just the internet inbetween doing its own weird thing as it sometimes does. :)
Oh, I see .... :)

But what I have to do now? I can't start MD .... instead I get *Errors occured*.

Posted: Thu May 12, 2011 1:37 pm
by hanako
Unfortunately your new problem is a lot harder to figure out because it's not something that's occurring in anyone else's game.

I'm guessing that you were actually still having connection problems and the update didn't download completely, leaving you with a broken game... which will have to be picked over while we try to figure out what bits can be replaced enough to allow you to at least launch it and try again to download a full update.

Sorry. :( All I can say is that we're still looking at it.