Page 1 of 1

Question about version 1.0.18.1

Posted: Fri Aug 05, 2011 1:59 pm
by cuddlyEmo
Hi.

Thing is:
I bought my game in version 1.0.13 and then upgraded to 1.0.20. BUT. there were changes in version 1.0.18.1, but I didn't upgrade to that version before the other one, and now I don't have e.g. the Wiggle Wand or any of the other changes.
It also says that downgrading will probably break my game :shock:
So. Is it possible to downgrade without breaking my game, or is this one of those "Buahahaha! Too bad, kiddo."-situations?? :?

Posted: Sat Aug 06, 2011 5:41 am
by Spiky Caterpillar
1.0.20 and 1.0.21 both include all earlier changes, so everything in 1.0.18.1 should be available if you upgraded to either. However, the Wiggle Wand will not be automatically added to your inventory - you will need to go to the magic store to buy it, like most equipment.

Updates usually contain all previous changes; the only exception is if we need to update the updater before a future update is installed. (But the last time that happened was 0.2.82.2, IIRC.)

If the Wiggle Wand does not show up in the store, it's possible that something went wrong during the update - in which case, 'Reset to 1.0.20' *can* be done safely.

Posted: Mon Aug 08, 2011 10:28 am
by cuddlyEmo
I have tried to reset the version multiple times now, however it still won't show up in the magic store, neither in old games nor games I just started...

Posted: Tue Aug 09, 2011 6:09 am
by Spiky Caterpillar
What operating system version are you using? Does the updater menu show the current version as 'MagicalDiary-1.0.21', or something else?

Does updating to 1.0.22 (released as an alpha five minutes ago) give you access to the Wiggle Wand in the store?

Posted: Sat Aug 13, 2011 10:45 am
by cuddlyEmo
no, mine says "1.0.20"...

again, no. when upgrading to the alpha version of 1.0.22 the wiggle wand still doesn't show up in the store...

Posted: Sat Aug 13, 2011 6:59 pm
by cuddlyEmo
I've now downgraded to 1.0.18 and then back to 1.0.20.
The Wiggle Wand now shoes up in the magic store and my game still works just fine.

Anyway, thanks for trying to help me fixing it :)

Posted: Wed Aug 24, 2011 3:54 pm
by holeena
I'm having the same difficully -__- i'm unable to see the new item in the store so the update was not successful.

however running the update or downgrading back to my last version (which was 1.0.9) right before the game restarts I get this message:


I'm sorry, but an uncaught exception occurred.

AttributeError: 'NoneType' object has no attribute 'filename'

While running game code:

-- Full Traceback ------------------------------------------------------------

File "C:\Program Files (x86)\Magical Diary - Horse Hall\renpy\bootstrap.py", line 270, in bootstrap
File "C:\Program Files (x86)\Magical Diary - Horse Hall\renpy\main.py", line 382, in main
File "C:\Program Files (x86)\Magical Diary - Horse Hall\renpy\main.py", line 116, in run
File "C:\Program Files (x86)\Magical Diary - Horse Hall\renpy\warp.py", line 101, in warp
AttributeError: 'NoneType' object has no attribute 'filename'

While running game code:

Ren'Py Version: Ren'Py 6.11.2b

Posted: Wed Aug 24, 2011 8:17 pm
by Spiky Caterpillar
I'm not sure why it's crashing there. What version does the game say you have installed when you try to update? What does updating to 1.0.25.7 do, if anything? What version of Windows are you using? Do you have an antivirus program running, and if so which one and is it interfering with the update?