Seeking Science Explorers for Steam beta

A fast-paced, light-hearted RPG where schoolgirls save the world from aliens.

Moderator: Spiky Caterpillar

Message
Author
User avatar
Spiky Caterpillar
Posts: 402
Joined: Thu Dec 04, 2008 3:34 am
Contact:

Re: Seeking Science Explorers for Steam beta

#16 Postby Spiky Caterpillar » Thu Mar 13, 2014 2:22 am

To verify the download cache:
Right-click on the game. Select 'Properties'. Go to the 'Local Files' tab. Click 'Verify integrity of game cache'. It's normal for it to report about 50 files need redownloading since you ran it successfully.

c0000005 is an access violation, which usually indicates a memory allocation bug of some sort - however, I'm not sure why there'd be one.

If verifying/redownloading doesn't fix the problem, other things to try:

Click 'Browse local files' and post the contents of ScienceGirls!.exe.log if it exists.
Deleting C:\Users\(your username)\AppData\Roaming\RenPy\science_girls\persistent will clear your settings, which might work around the bug if it's a driver problem.
Deleting game\steamsh.exe (in the Steam install folder for Science Girls) will keep it from loading the Steam API (so if that fixes it, then there's probably a bug in my steamsh that I need to fix)

Verify/redownload a second time and tell me how many files it says are changed (as that will tell me something about how far it's getting before crashing.)

wendymarlowe
Posts: 25
Joined: Thu Dec 12, 2013 4:19 am

Re: Seeking Science Explorers for Steam beta

#17 Postby wendymarlowe » Thu Mar 13, 2014 2:54 am

"51 files failed to validate and will be reacquired." Allowed them to load, closed and re-launched steam, got the same failure message. Tried verifying again immediately and got 41 files failing to validate this time (and the next).

No ScienceGirls!.exe.log file there, as far as I can tell.

Deleting C:\Users\(your username)\AppData\Roaming\RenPy\science_girls\persistent didn't seem to make any difference in letting me launch the game - I checked via shortcut, start menu, and Steam library menu.

Deleted game/steamsh.exe --> still won't start from any of the three methods.

Verifying/redownloading gives 42 files. (And still won't let me open the game.)

User avatar
Spiky Caterpillar
Posts: 402
Joined: Thu Dec 04, 2008 3:34 am
Contact:

Re: Seeking Science Explorers for Steam beta

#18 Postby Spiky Caterpillar » Thu Mar 13, 2014 3:12 am

What happens when you bring up the game install folder (through 'Browse local files'), quit the Steam client entirely, and start the game from the install folder directly? Do you have any virus scanners or other apps that modify running programs? Does turning them off make a difference? What colour depth is your screen set to? Is sound working? Are any other programs showing similar crashes? Have you changed any hardware?

Regrettably, I'm rather lost on this one :( I can understand bugs where things *never* work, but crashes when it used to work tend to be complex and hard to debug.

wendymarlowe
Posts: 25
Joined: Thu Dec 12, 2013 4:19 am

Re: Seeking Science Explorers for Steam beta

#19 Postby wendymarlowe » Thu Mar 13, 2014 3:39 am

Spiky Caterpillar wrote:What happens when you bring up the game install folder (through 'Browse local files'), quit the Steam client entirely, and start the game from the install folder directly?


Same error message.

Spiky Caterpillar wrote:Do you have any virus scanners or other apps that modify running programs? Does turning them off make a difference?


No virus scanners and nothing I can think of that would modify running programs - I tend to work off the "keep it streamlined, back up the important stuff, and rebuild from scratch every once in a blue moon if things go south" philosophy :-P

Spiky Caterpillar wrote:What colour depth is your screen set to? Is sound working? Are any other programs showing similar crashes? Have you changed any hardware?


Unfortunately, I can't make heads or tails of Windows 7's menus when it comes to things that should be simple like "How many colors does my monitor have?" - pretty sure it's "lots, and the same as I had before." Sound is working fine for other things (movies/internet/Minecraft) and although I had issues with Minecraft earlier today, I'm pretty sure it was on their end and the issue resolved quickly. Other Steam games run fine, and I haven't changed any hardware. The only real changes I can point to are the Java and the Steam updates.

Spiky Caterpillar wrote:Regrettably, I'm rather lost on this one :( I can understand bugs where things *never* work, but crashes when it used to work tend to be complex and hard to debug.

User avatar
phoenixgirl
Posts: 466
Joined: Sat Jun 02, 2007 8:36 am
Location: At the school of healing magic
Contact:

Re: Seeking Science Explorers for Steam beta

#20 Postby phoenixgirl » Thu Mar 13, 2014 10:17 am

I haven't had this problem on my end but I can suggest a couple of things to try whenever I've had certain programs not work for me in the past. If it's a Java issue, perhaps try disabling it? I disable Java myself. Or if there isn't another solution, perhaps you could run a system restore? Go back to a point before the problem occurred?
Please help and support me here.

User avatar
hanako
Site Admin
Posts: 3110
Joined: Fri Apr 13, 2007 1:44 am

Re: Seeking Science Explorers for Steam beta

#21 Postby hanako » Thu Mar 13, 2014 2:08 pm

I can't see any reasonable way disabling Java would have an effect since the game doesn't use Java. (But sometimes computers aren't reasonable.) If Java messed something up in the Windows configurations when it was updating that might break other things but disabling Java probably wouldn't un-break them. Dunno.

One thing that might be interesting to look at - do you still have the previous version of the game on your computer somewhere? The non-steam one? If THAT no longer runs either then it would suggest the issue being something that had updated on the computer.

wendymarlowe
Posts: 25
Joined: Thu Dec 12, 2013 4:19 am

Re: Seeking Science Explorers for Steam beta

#22 Postby wendymarlowe » Thu Mar 13, 2014 2:32 pm

Hmmm - yes, I do still have the other one, and it gives the same error message. (LLTQ and The Royal Trap both work fine, though, as do other Steam games - seems like the problem is restricted to Science Girls.)

Problem signature:
Problem Event Name: APPCRASH
Application Name: ScienceGirls!.exe
Application Version: 0.0.0.0
Application Timestamp: 4917df95
Fault Module Name: StackHash_c51c
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 94ae0000
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: c51c
Additional Information 2: c51c3a7990f8a4215c04d38604988dcf
Additional Information 3: 2ff6
Additional Information 4: 2ff67d422fb675aeed69f09799e8be35

wendymarlowe
Posts: 25
Joined: Thu Dec 12, 2013 4:19 am

Re: Seeking Science Explorers for Steam beta

#23 Postby wendymarlowe » Sun Mar 16, 2014 8:18 pm

Steam updated something today (~5 seconds, maybe?) and now the game works. So I have no idea what happened.

wendymarlowe
Posts: 25
Joined: Thu Dec 12, 2013 4:19 am

Re: Seeking Science Explorers for Steam beta

#24 Postby wendymarlowe » Sun Mar 16, 2014 8:29 pm

Not a game-breaking glitch, but I just beat found a bunch of alien seeds in a hole (guarded by a turnip thingy in an underground maze, hope you know what I'm talking about) and the game minimized itself for no particular reason. It opened again just fine to where it left off, but odd.

ETA: Did it again when I got the "pomelo" achievement.

wendymarlowe
Posts: 25
Joined: Thu Dec 12, 2013 4:19 am

Re: Seeking Science Explorers for Steam beta

#25 Postby wendymarlowe » Mon Mar 17, 2014 2:53 pm

Gah - it was working fine yesterday! I got the text popup when I quit (which I emailed you), immediately reloaded my save and quit again without getting the text popup, then when I tried to start the game today it gave me the same error message I posted upthread :-(

_SE_
Posts: 9
Joined: Fri Oct 10, 2008 9:33 pm

Re: Seeking Science Explorers for Steam beta

#26 Postby _SE_ » Mon Mar 17, 2014 5:08 pm

A couple of small bugs- a few times today I noticed Spiked Balls listed as Stealth Balls when I selected them after they were decloaked. Also, when I quit the game it gave me this traceback.

Code: Select all

I'm sorry, but an exception occured while executing your Ren'Py
script.

Exception: Render count is 9 at shutdown. This probably indicates a memory leak bug in Ren'Py.

While running game code:

-- Full Traceback ------------------------------------------------------------

  File "C:\Program Files (x86)\Steam\steamapps\common\ScienceGirls\renpy\bootstrap.py", line 255, in bootstrap
  File "C:\Program Files (x86)\Steam\steamapps\common\ScienceGirls\renpy\main.py", line 320, in main
  File "C:\Program Files (x86)\Steam\steamapps\common\ScienceGirls\renpy\display\render.py", line 100, in check_at_shutdown
Exception: Render count is 9 at shutdown. This probably indicates a memory leak bug in Ren'Py.

While running game code:

Ren'Py Version: Ren'Py 6.9.2a
Game version: ScienceGirls!-1.3.3

User avatar
Spiky Caterpillar
Posts: 402
Joined: Thu Dec 04, 2008 3:34 am
Contact:

Re: Seeking Science Explorers for Steam beta

#27 Postby Spiky Caterpillar » Tue Mar 18, 2014 12:57 am

_SE_, Wendy - the game should have created a leaks.debug file and a group of files named renderleak.(number).png in the save directory. Can you zip them up and upload them to me at http://spikycaterpillar.com/savegame-upload.html ? (And also send let me know when you've uploaded, since the script doesn't currently auto-notify me - I should fix that sometime)

Wendy - the minimization looks like a bug in the achievement unlock helper; are you playing in fullscreen or windowed mode? Do the achievements show up in Steam or only in the game? Still the same Win7 machine, I assume?

User avatar
hanako
Site Admin
Posts: 3110
Joined: Fri Apr 13, 2007 1:44 am

Re: Seeking Science Explorers for Steam beta

#28 Postby hanako » Tue Mar 18, 2014 1:05 am

Note that it's difficult to view achievements on Steam for a game that's not officially released, so if you can't get the achievement viewer on steam's side to work properly that's probably normal. However, you should be able to see at least the most recent unlocked graphic by the entry in your library.

wendymarlowe
Posts: 25
Joined: Thu Dec 12, 2013 4:19 am

Re: Seeking Science Explorers for Steam beta

#29 Postby wendymarlowe » Tue Mar 18, 2014 1:16 am

I've only gotten the one achievement so far (and had the minimization bug more than once), but the achievement that did show up was in the Steam pop-up menu (over the desktop). I'm playing in fullscreen mode.

I can't find any leaks.debug file, but I'm uploading the renderleak pngs now.

ETA: Ooh, actually, Steam says I've unlocked two achievements, but it won't let me see what the other one is :-P Was there one early in the game?

User avatar
hanako
Site Admin
Posts: 3110
Joined: Fri Apr 13, 2007 1:44 am

Re: Seeking Science Explorers for Steam beta

#30 Postby hanako » Tue Mar 18, 2014 1:26 am

The seeds are also an achievement.


Return to “Science Girls!”

Who is online

Users browsing this forum: No registered users and 2 guests